br-linux

Artigos br-linux.org
Artigos sobre Linux em bom português, originais e com qualidade

Instalando Lucent winmodem no Knoppix 3.3
Publicado em 17 de abril de 2004

Nosso amigo Antônio Carlos V. da Silva,(acvsilva acvsilva@terra.com.br), editou um pequeno tutorial ensinando a configurar o popular modem Lucent no Knoppix 3.3.

Pode ser facilmente adaptado para sua distribuição. ;-)

Instalando Lucent winmodem no Knoppix 3.3

por Antonio Carlos V. da Silva - acvsilva_AT_terra.com.br
se aplica aos lucent/agere com chip SV92P


O kernel do knoppix 3.3 é compilado com o gcc-2.95 e os drivers do lucent, com o gcc-3.x. Isto cria uma incompatibilidade que impede o usuário de instalá-los.
Assim, vamos recompilá-los com o 2.95 para podermos navegar na internet sem problemas... ;-))

1) Baixe os fontes - ltmodem-826a9.tar.gz - em aqui.


2) Como root, execute:
# mv /usr/bin/gcc /usr/bin/gcc_old
# ln -s /usr/bin/gcc-2.95 /usr/bin/gcc


3) Descompacte o arquivo do driver num local qualquer (ex.: /tmp):
# tar -xvzf ltmodem*gz
# cd ltmodem-826a9/source


4) Recompile os drivers:
# gcc ltmodem.c
# gcc serial-lt.2.X.c (onde X corresponde à série do kernel: se 2.4.alguma_coisa, X=4)
# cd .. (saindo do diretório source)


5) Construa o módulo para debian:
# ./build_deb


6) Ignore as mensagens que aparecerem. Após o pacote ser feito, clique nele para instalação automática...


7) Configure seu discador preferido e navegue tranquïlo... ;-))


Autor: Antonio Carlos V. da Silva -
Email: acvsilva_AT_terra.com.br

Postado por fuji em abril 17, 2004 12:30 AM

Comentários para "Instalando Lucent winmodem no Knoppix 3.3"

» Postado por: (fuji) Mike Shigueru Matsumoto em abril 17, 2004 12:36 AM, 200.225.194:

    Aconselho aos iniciantes usarem o "kppp" do KDE. Muito fácil e simples. Bem parecido com o "Conexão Dialup" do Windows.

    Abraços a todos

 

» Postado por: carlos em abril 17, 2004 12:47 AM, 200.147.125:

    Há um erro no tutorial: ele >>> NÃO <<< se aplica aos chips SV92P... Ainda não possuem suporte no linux...

 

» Postado por: Eduardo Leandro em abril 23, 2004 05:39 PM, 201.8.168.1:

    Acho que bem lá no alto onde tem o e-mail do Antonio Carlos há uma frase dizendo por Antonio Carlos V. da Silva - acvsilva_AT_terra.com.br
    se aplica aos lucent/agere com chip SV92P

    Certo ou errado ?

 

» Postado por: Eduardo Leandro em abril 23, 2004 05:41 PM, 201.8.168.1:

    Desculpe Carlos, nao percebi que se tratava do dono do artigo a correção acima.
    valeu

 

» Postado por: Samuel em maio 14, 2004 09:32 PM, 200.101.73.:

    Antônio Carlos o link ai em cima nam esta funcionando vc nao sabe de outro endereco, nao aguento mais ter que urar o ruindows,e so ainda o uso por causa da internet.

    Valeu

 

» Postado por: washington em maio 15, 2004 04:50 PM, 200.216.156:

    preciso aprender como usar o dialup no knoppix3.3 ou como obter um discador que configure o numero , e como saber ser o modem esta´instalado?

 

» Postado por: Anderson Vieira em maio 18, 2004 02:08 AM, 200.205.95.:

    Será que essa configuração se aplica no fax modem hsp56 pois estou tentando configurar esse modem e não vai de jeito nenhum ....

 

» Postado por: anon em maio 20, 2004 12:20 AM, 200.191.176:


    Pô ... dá uma olhado no que vc disse. Vc testou isso ? Vc tem esse _SOFT_ modem rodando no Linux ? _eu_ indigente não ... o "cara" (mantainer do codigo ltmodem) MarS disse que por enquanto _não_ dá ... (peskise)

 

» Postado por: anon em maio 20, 2004 12:31 AM, 200.191.176:

 

» Postado por: ronaldo em maio 27, 2004 08:16 PM, 200.144.123:

    passe o link certo pois este esta com problema

 

» Postado por: Reifison em maio 28, 2004 02:47 PM, 200.199.244:

    Olá eu, sou inciante no uso do linux. estou com dois problemas.
    1. o modem, ele é configurado, mas sempre q mando discar da sem tom de linha, será q estou fazendo algo errado?
    2. a placa de som, teve uma vez q eu dei boot (uso o linux pelo cd) e ela funcionava para os joguinhos do linux, depois eu fiquei fuçando e consegui fazer ela tocar mp3, e agora toda vez q eu dou boot pelo cd, não consigo ouvir nenhum tipo de som...
    Eu uso o Linux Kurunim, se alguém puder me ajuadar agradeço,...

 

» Postado por: celmo em maio 29, 2004 06:52 PM, 200.207.227:

    PLACA DE SOM - eu estava com esse problema enquanto usava o kurumin 3 pelo CD. Qd instalei no HD esse problema com a placa de som desapareceu. Quanto ao modem, ainda nao consegui usar.

 

» Postado por: André H. Freitas em junho 4, 2004 01:33 AM, 200.234.119:

    Esse modem da Lucent ta dificil de fazer funcionar hein. A única vez que consegui instalar ele dava sem tom de discagem na sequência. Tá muito difícil.

 

» Postado por: online poker em agosto 15, 2004 03:32 PM, 203.101.85.:

 

» Postado por: Briana Banks em setembro 10, 2004 12:56 AM, 205.218.254:

 

» Postado por: pai gow em outubro 5, 2004 10:24 AM, 200.48.218.:

 

Antes de comentar...

- Preserve a qualidade desta discussão
- Leia os Termos de Uso.
- Este formulário deve ser usado para comentários sobre a notícia. Se você tem dúvidas ou precisa de ajuda, use o Fórum.
- Mantenha o foco nos argumentos e no assunto
- Não faça ataques pessoais.
- Pense 5 vezes antes de entrar em discussões inúteis, como "qual é a melhor distribuição/ambiente gráfico/linguagem de programação/etc.", mesmo se alguém já tiver provocado - um erro não justifica o outro
- Não seja um e-mala ;-)

Envie seu comentário









Lembrar as informações pessoais?


Atenção: Este formulário deve ser usado para comentários sobre a notícia. Se você tem dúvidas ou precisa de ajuda, use o Fórum, onde mais pessoas estarão disponíveis para respondê-lo..






Nota: os comentários pertencem a seus respectivos autores e são de responsabilidade de quem os postou. O restante desta nota está disponível sob a licença GNU FDL, exceto se explicitamente declarado em contrário.